ploppy

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 28 total)
  • Author
    Posts
  • in reply to: search help needed #94632

    ploppy
    Member

    thanks ever so much tim. much appreciate your time and effort.

    in reply to: search help needed #94628

    ploppy
    Member

    tim

    so i understand you correctly, are you saying code in the new.php file is enough to perform and display the results from the click of the find button? i have included the php file i am using to display data. many thanks for your help.

    <?php

    // Include the information needed for the connection to
    // MySQL data base server.
    include("dbconfig.php");
    //since we want to use a JSON data we should include
    //encoder and decoder for JSON notation
    //If you use a php >= 5 this file is not needed
    include("JSON.php");

    // create a JSON service
    $json = new Services_JSON();

    // to the url parameter are added 4 parameter
    // we shuld get these parameter to construct the needed query
    // for the pager
    $examp = $_GET["q"];

    // get the requested page
    $page = $_GET['page'];
    // POST how many rows we want to have into the grid
    // rowNum parameter in the grid
    $limit = $_GET['rows'];
    // POST index row - i.e. user click to sort
    // at first time sortname parameter - after that the index from colModel
    $sidx = $_GET['sidx'];
    // sorting order - at first time sortorder
    $sord = $_GET['sord'];

    // if we not pass at first time index use the first column for the index
    if(!$sidx) $sidx =1;
    // connect to the MySQL database server
    $db = mysql_connect($dbhost, $dbuser, $dbpassword)
    or die("Connection Error: " . mysql_error());

    // select the database
    mysql_select_db($database) or die("Error conecting to db.");

    // calculate the number of rows for the query. We need this to paging the result
    $result = mysql_query("SELECT COUNT(*) AS count FROM jqgrid");
    $row = mysql_fetch_array($result,MYSQL_ASSOC);
    $count = $row['count'];

    // calculation of total pages for the query
    if( $count >0 ) {

    in reply to: search help needed #94626

    ploppy
    Member

    tim

    thanks very much for a detailed explanation. i totally get everything you have said and i know that the passed vars need to be processed by php & mysql. but what i cannot see is where to specify the php page to do this. for example, i have new.php in my sample code that displays the listing. i then have edit.php which handles the add,del etc of records. does the search need to be built into one these files? for example, in new.php as above, does that become new.php?q=1 because i noticed from your sample files that $examp var is expecting this in a $_REQUEST field? if that is the case, do i just build the search criteria into new.php? because the way i see it, there is no other way to pass the values to say search.php as per the demo files? am i getting closer?

    many thanks for your time and help tim.

    in reply to: search help needed #94622

    ploppy
    Member

    tim

    these are filters that are being posted as pre firebug console.

    _search

    in reply to: search help needed #94620

    ploppy
    Member

    any further help with this please. thanks

    in reply to: Navgrid not displaying icons #94566

    ploppy
    Member

    hi tim. thanks for reply. where in the docs does it state the load order? and also, is there docs for including in the min build? also, what is github? jeez, i seem to have missed some very important steps? many thanks for your help.

    in reply to: Navgrid not displaying icons #94547

    ploppy
    Member

    here are 2 examples of what i am referring too.

    1) the warning appears whenever i create icon. ie, search:true

    2) if i enable say the find with search:true then what you see in image 2 happens. i cannot move forward until i understand why this is happening. i have read over again the docs and wiki and my code is identical. where is it going wrong. many thanks tony.

    warning message

    search button

    in reply to: Navgrid not displaying icons #94545

    ploppy
    Member

    tony

    i have now got a working grid thank you, but the navGrid icons do nothing when i click them and also beneath the pager the text

    'Warning no row selected' appears and i haven't selected a row. all i have done is load the grid. what am i doing wrong? i have posted revised code. cheers

    My First Grid

    in reply to: Navgrid not displaying icons #94544

    ploppy
    Member

    thank you tony. shall start from scratch. cheers

    in reply to: Navgrid not displaying icons #94540

    ploppy
    Member

    any help with this please? thanks

    in reply to: cellEdit not updating #91002

    ploppy
    Member

    Tony

    i didn't think the question was unreasonable. can anyone answer it? it's taken 5 days to reach this stage and still no answer. thanks

    in reply to: cellEdit not updating #90975

    ploppy
    Member

    Tony

    Guess what i asking is, if normal edit works should celledit work using the same file or do i have to code something different? thanks

    in reply to: cellEdit not updating #90940

    ploppy
    Member

    thanks for reply Tony.

    However, i am confused by your reply? if you look at my original post, you will see that i am using my own edit.php file which is working fine when i use it to edit entries based on checkbox selection, it edits fine. i am using that same file which has all the required db entries etc. do i need to use a different code in celledit than in edit? why does my edit.php not work in celledit but works with normal edit?

    many thanks

    in reply to: cellEdit not updating #90880

    ploppy
    Member

    any help with this please? thanks

    in reply to: custom button incorrect #90555

    ploppy
    Member

    thanks for reply tony. is there a way to incorporate an image say 16×16 into a icon set? many thanks

Viewing 15 posts - 1 through 15 (of 28 total)

Stay connected with us in your favorite flavor!